GreenLink Softphone Down

Incident Report for GreenLink Networks

Resolved

We have found the root cause of the issue and resolved it, the GreenLink softphone is back online working as expected.
Posted Oct 15, 2025 - 15:45 EDT

Investigating

The GreenLink softphone is currently down, displaying an error. We are actively working to resolve it.
Posted Oct 15, 2025 - 13:05 EDT
This incident affected: Cloud Phone Services.