Issues downloading Faxes and Media Files from the Customer Portal

Incident Report for GreenLink Networks

Resolved

This incident has been resolved.
Posted Feb 01, 2024 - 14:36 EST

Investigating

We are looking into a current issue with downloading faxes and reproducing media files (voicemails, call recordings, etc.) from the Customer Portal. We will provide more updates on this as soon as possible.
Posted Feb 01, 2024 - 13:47 EST
This incident affected: Customer Portal.