Call Origination/Termination - Issues
Incident Report for GreenLink Networks
Resolved
We are receiving reports of calls coming in blank; with no audio. Also the caller can't hear you. Our engineering team is currently investigating.

Issue has been now resolved
Posted Oct 13, 2021 - 08:30 EDT