All services are 100% functional. We are closely monitoring our systems.
Posted Aug 01, 2025 - 14:37 EDT
Monitoring
We’ve identified and applied a fix for a recent issue that affected a small number of VOIP users. One of our internal systems applied an overly aggressive traffic policy, which unintentionally impacted service for a few customers.
The adjustment has been made, and services are now stable. Our team is continuing to monitor to ensure everything remains fully operational.
We appreciate your patience and understanding as we worked to resolve this quickly.
Posted Aug 01, 2025 - 10:50 EDT
Identified
We’ve identified an issue that caused intermittent VOIP service disruptions for a small subset of customers. The vast majority of users remain unaffected, and core services continue to operate as expected.
Our engineering team is actively reviewing the situation to ensure everything returns to full stability. We’re treating this with high priority and will share updates as we have more information.
Thank you for your patience.
Posted Aug 01, 2025 - 10:44 EDT
This incident affected: Cloud Phone Services and Mobility Suite (Softphone Apps).