We are continuing to monitor for any further issues.
Posted Aug 29, 2025 - 14:40 EDT
Monitoring
We are aware that our company’s listing in the FCC’s Robocall Mitigation Database was temporarily removed. The RMD is a public list of approved and vetted providers who are known not to originate or permit illegal robocalls. Our removal was the result of an administrative error and was not related to our compliance, security practices, or any allowance of unlawful robocalling activity on our platform.
Our systems remain fully secure and by design blocks any other unauthorized call activity. We are already working closely with the FCC to correct the error and reinstate our registration as quickly as possible.
In the meantime, you may notice intermittent issues with certain call routing, but we expect these to be temporary. Please know that your service and security remain our top priority, and we will keep you informed as this is resolved.
Posted Aug 28, 2025 - 11:59 EDT
Identified
We are aware that our company’s listing in the FCC’s Robocall Mitigation Database was temporarily removed. The RMD is a public list of approved and vetted providers who are known not to originate or permit illegal robocalls. Our removal was the result of an administrative error and was not related to our compliance, security practices, or any allowance of unlawful robocalling activity on our platform.
Our systems remain fully secure and by design blocks any other unauthorized call activity. We are already working closely with the FCC to correct the error and reinstate our registration as quickly as possible.
In the meantime, you may notice intermittent issues with certain call routing, but we expect these to be temporary. Please know that your service and security remain our top priority, and we will keep you informed as this is resolved.
Posted Aug 27, 2025 - 11:29 EDT
This incident affects: Cloud Phone Services, SIP Trunk Services, and Mobility Suite (Softphone Apps).