Customer and Partner Portals Service Disruption

Incident Report for GreenLink Networks

Resolved

Our cloud service provider AWS has announced this disruption as completely resolved. All systems are operational again.
Posted Oct 21, 2025 - 08:24 EDT

Monitoring

The AWS cloud services are slowly being reestablished, which allowed the Customer and Partner Portals to become functional again. It is possible that some intermittent behavior manifests while the situation is fully addressed and considered resolved.

We will keep monitoring and updating as soon as more information becomes available.
Posted Oct 20, 2025 - 16:06 EDT

Identified

GreenLink is currently affected by our cloud service provider AWS, there is intermittent behavior in the Customer Portal and Partner Portal, with most of the functionality disrupted. We are actively working on this to get the services back up.

The ongoing status can also be tracked here: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:47 EDT
This incident affected: Customer Portal and Partner Portal.