Call Recordings Affected

Incident Report for GreenLink Networks

Resolved

We have identified the root cause of this issue and applied the required fix. Call recordings are now fully operational.
Posted Jun 25, 2026 - 13:43 EDT

Investigating

The call recordings are currently affected and therefore unavailable. We are investigating the underlying cause to provide a fix as soon as possible.
Posted Jun 23, 2026 - 16:42 EDT
This incident affected: Customer Portal.