Outbound Faxes Affected

Incident Report for GreenLink Networks

Resolved

We have identified the root cause of this issue, and it is resolved. Faxes are operational.
Posted Jun 09, 2026 - 08:24 EDT

Investigating

Outbound faxes are currently affected, we are actively working to find and address the root cause.
Posted Jun 08, 2026 - 15:32 EDT
This incident affected: Customer Portal.