GLN Services currently down
Incident Report for GreenLink Networks
Resolved
This incident has been resolved. All services are operational again.
Posted May 28, 2024 - 14:56 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 28, 2024 - 11:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted May 28, 2024 - 11:25 EDT
Identified
Significant weather patterns have impacted connectivity and created service interruptions. We are working to restore service and will provide updates as quickly as possible.
Posted May 28, 2024 - 11:22 EDT
Investigating
We are aware of registration issues with our softphones and also the PBX Settings section within the Customer Portal. This is being actively worked on and we will update this page shortly.
Posted May 28, 2024 - 09:46 EDT
This incident affected: Cloud Phone Services, SIP Trunk Services, Mobility Suite (Softphone Apps), and Customer Portal.