GLN Softphone App Background Issues in iOS

Incident Report for GreenLink Networks

Identified

We've narrowed down the problem to a global issue we have regarding calls on iOS18.4 and 18.5. Reports indicate that it is only the first call (inbound or outbound) after the app is brought forward from the background. We don't have an exact ETA at the moment, as Apple has made some fundamental changes to the operating system that are causing this to happen.

This is a priority issue for us and we are actively working to provide a resolution.
Posted Jun 18, 2025 - 14:17 EDT

Investigating

The GLN Softphone App iOS users are currently experiencing two separate issues:

1- Outbound calls not ringing and there's no audio on the first attempt. This happens when the application is closed (not open in background) and the user opens it; while making a first attempt to call, the user cannot hear when the other phone is ringing and there's no audio when they answer. However, when the user makes a second call, everything works properly.

2- Inbound calls not ringing and going directly to voicemail. This happens both when the app is closed AND when the app is open in the background. When the user receives an inbound call, no notification nor ring is displayed. The only way for the user to receive the notification is by having the application open on-screen.

We are currently investigating the root cause of this issue to provide a fix as soon as possible.
Posted May 29, 2025 - 11:04 EDT
This incident affects: Mobility Suite (Softphone Apps).