Issues with Outbound and Hybrid Faxes

Incident Report for GreenLink Networks

Resolved

The root cause of this issue has been identified and addressed. Outbound and Hybrid faxes are operational.
Posted Jul 15, 2025 - 14:00 EDT

Investigating

There is currently a global issue affecting Outbound and Hybrid faxes. We are actively investigating and working to resolve it.
Posted Jul 15, 2025 - 12:49 EDT
This incident affected: Customer Portal.